0

Configuring the Build Environment ( Windows 7) Error

asked 2014-08-02 01:29:56 -0700

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I think I have configured the environment correctly followed the guide Configuring the Build Environment ( Windows 7).

But,I still can not compile the AllJoyn resource code.it saied "the 'cl' is not the internal or external command".

thanks

edit retag flag offensive close merge delete

Comments

Please add details to the questions. I do not know what the error you encounter from the posting.

bspencer ( 2014-08-04 11:14:58 -0700 )edit

I have added environment variables when I installed the Microsoft Visual Studio 2012,but when I compiled the AllJoyn core ,it told me “cl is not external or internal order, is not to run a program or batch file” I do not have any idea about it .I am really sorry to bother you ,thanks .

KAKA ( 2014-08-04 18:03:27 -0700 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2014-08-05 15:38:28 -0700

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The error relating to "cl is not recognized as an internal or external command" is due to having your path variable no setup correctly. This could be due to not restarting after installing Microsoft Visual Studio, not opening a new cmd window after modify the PATH variable. Or it could just be that the PATH variable was not updated and you will need to go edit the PATH environment variable to point to the correct location.

edit flag offensive delete publish link more

Comments

You are so kind! Thank you very much !

KAKA ( 2014-08-07 19:46:05 -0700 )edit
0

answered 2014-08-08 09:37:24 -0700

georgen gravatar image

SCons tries to set up the environment for Microsoft Visual Studio automatically. However, it is really bad at detecting what environment you have installed.

when you run scons you need to tell it what version of Microsoft Visual Studio you are using. To tell SCons the version of Visual Studio you are using you need to specify the build variable MSVC_VERSION Since you said you are suing Microsoft Visual Studio 2012 MSVC_VERSION=11.0 or MSVC_VERSION=11.0Exp for the express version.

You scons command should look something like this:

scons OS=win7 CPU=x86_64 MSVC_VERSION=11.0 BINDINGS="" WS=off

That will build the 64-bit version of just the C++ alljoyn code base. If that works you can start trying to add in other languages like Java, C, etc. I am not completely sure but if you are using the express version of Visual Studio I think you are limited to 32-bit builds and CPU=x86 should be used instead of the 64-bit option.

edit flag offensive delete publish link more

Comments

I am really grateful for the help you have given to me !

KAKA ( 2014-08-08 12:07:50 -0700 )edit
Login/Signup to Answer

Stats

Asked: 2014-08-02 01:29:56 -0700

Seen: 271 times

Last updated: Aug 08 '14