0

OnboardingClient ConfigureWifi error 0x0015

asked 2016-01-07 04:31:38 -0700

rusyasoft gravatar image

updated 2016-01-09 08:08:35 -0700

praveenb gravatar image

Hi there i got an error while onboarding OpenWRT Yun device Onboarder is my pc.

It seems everything goes well until ConfigureWifi

ConfigureWiFi errorName: org.alljoyn.Bus.ErStatus errorMessage: 0x0015

Call to ConfigureWiFi failed ER_BUS_REPLY_IS_ERROR_MESSAGE

please help

p.s: i think some one before gave similar question, because google keep finding it for me. But when i click it i come to Allseen webpage which says its no longer exists :(

Please guys dont remove old forums

I have tried Android Onboarding Client as an Onboarder and it works perfectly.

I have an intuitive feeling that its somehow related to security things in AlljoynOnboarding. Default password is 000000 right ?

here the trace:

8u5cXNgf.2 OnboardingClient ConfigureWiFi
1.285 TRACE Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:149 | In OnboardingClient ConfigureWiFi

1.295 HL_DBG Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:192 | ConfigureWiFi errorName: org.alljoyn.Bus.ErStatus errorMessage: 0x0015

Call to ConfigureWiFi failed ER_BUS_REPLY_IS_ERROR_MESSAGE

1.295 TRACE Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:212 | In OnboardingClient ConnectTo Call to ConnectTo succeeded

1.296 TRACE Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:237 | In OnboardingClient OffboardFrom Call to OffboardFrom succeeded

Leaving session id = 2740942045 with :8u5cXNgf.2 status: ER_OK

1.300 TRACE Onboarding lepDisp1_0 ...src/OnboardingClient.cc:72 | In OnboardingClient Destructor

wlan0: CTRL-EVENT-DISCONNECTED bssid=b4:21:8a:f0:0f:ad reason=4 locally_generated=1

wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD

wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN

wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN

wlan0: SME: Trying to authenticate with b4:21:8a:f0:0f:ad (SSID='AJ_OpenWRT b4:21:8a:f0:0f:ad' freq=2437 MHz)

wlan0: SME: Trying to authenticate with b4:21:8a:f0:0f:ad (SSID='AJ_OpenWRT b4:21:8a:f0:0f:ad' freq=2437 MHz)

wlan0: Trying to associate with b4:21:8a:f0:0f:ad (SSID='AJ_OpenWRT b4:21:8a:f0:0f:ad' freq=2437 MHz)

wlan0: Associated with b4:21:8a:f0:0f:ad

wlan0: CTRL-EVENT-CONNECTED - Connection to b4:21:8a:f0:0f:ad completed [id=0 id_str=]

14.823 ** ERROR TCP JoinS-3 ...outer/TCPTransport.cc:3222 | TCPTransport::Connect(): Failed: ER_CONN_REFUSED

14.823 ** ERROR ALLJOYN_OBJ JoinS-3 .../router/AllJoynObj.cc:1315 | trans->Connect(tcp:addr=192.168.240.1,port=9955) failed: ER_CONN_REFUSED

16.832 ** ERROR TCP JoinS-4 ...outer/TCPTransport.cc:3222 | TCPTransport::Connect(): Failed: ER_CONN_REFUSED

16.832 ** ERROR ALLJOYN_OBJ JoinS-4 .../router/AllJoynObj.cc:1315 | trans->Connect(tcp:addr=192.168.240.1,port=9955) failed: ER_CONN_REFUSED

Here more detail trace with some of my personal embedded debug messages. May be it would be useful (I have embeded debug message codes into OnboardingClientMain.cc, OnboardingClient.cc, ProxyBusObject.cc):

:8u5cXNgf.2 OnboardingClient ConfigureWiFi
1.285 TRACE Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:149 | In OnboardingClient ConfigureWiFi
1.286 TRACE Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:168 | Before calling reply message ConfigureWiFi
1.286 TRACE Onboarding lepDisp1_0 ...rc/OnboardingClient.cc:178 | Before calling methdoCall Rustam>> status of msg->GetType() at first 0 Rustam>> Alljoyn encrypted flag is on Rustam>> status of msg->GetType() before CallMsg 0 Rustam>> status of msg->GetType() after CallMsg 1 Rustam>> status of msg->GetType ...
(more)
edit retag flag offensive close merge delete

Comments

The older question ( https://ask.allseenalliance.org/question/1862/onboarding-configurewifi-returns-an-error/ ) does not have an answer. Can you provide some additional information viz. packet traces when this happens? Have you tried using Android Onboarding app to do this operation?

praveenb ( 2016-01-07 16:38:20 -0700 )edit

I have added trace list

rusyasoft ( 2016-01-07 19:34:19 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-01-08 22:06:11 -0700

rusyasoft gravatar image

I found the problem solution and it was too simple (as always)

I messed up with passcode of oBInfo. I thought it already supports password conversion into HEX, but it wasn't. So the error didn't said anything about it. Anyway, the passcode must be converted into 2character hex from ASCII table. And it works with noo problem.

And why its not mentioned anywhere in the code :(

If someone knows where its mentioned officially in documents, please let us know the link.

Thanks!

edit flag offensive delete publish link more

Comments

Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2016-01-07 04:31:38 -0700

Seen: 264 times

Last updated: Jan 09 '16