Fast Forward Playback, Linux Audio Service Framwork

asked 2014-03-30 23:25:30 -0700

AAudio gravatar image


I've asked this on the forum before and would like to update it. My original Post was as follows.

I've recently found someone with a similar question being asked on the original alljoyn forum. I would like to know if anyone has tried out the Linux audio service framework stock sample and heard actual speed music.

I am having problem working with the Linux audio service framework sample. I have successfully compiled the about core and audio framework and was able to run the sample audio SinkService and SinkClient. But when I proceed with playing the WAV file, the audio seems to be playing at an abnormally fast rate. Meaning for example an entire 3 min audio file was completed in 10 seconds like if I was fast-forwarding the music. I’ve tried different WAV (all with standard 16bit and 44.1kHz) file and also creating one myself. All of them were fast-forwarded. I’ve also tried aplay <file.wav> to verify the audio wav files and they played normally.</file.wav>

Was wondering if I can get any help on this. I suspect that the SinkClient time is slower and trying to catch up to the SinkService’s time resulting in the audio being fast forwarded.

the music that we are using contains the following type of information.

mSampleRate 44100 mBytesPerFrame 4 mBytesPerSecond 176400 bitsPerChannel 16 mChannelsPerFrame 2 mMaxBufferSize 882000 mFifoLowThreshold 705600 mBufferSize 16384



edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted

answered 2014-03-31 08:58:56 -0700

bspencer gravatar image

Hi George,
We have found the cause of the problem and it is a missing inclusion of the asound library when compiling. Please see my posting here: https://ask.allseenalliance.org/question/39/audio-framework-for-desktop/
Basically you just need to add audio_env.Append(LIBS = [ 'asound' ]) to the root SConscript, clear out the build folder in both the audio project and the core/alljoyn project then recompile and it will playback at a normal rate.

edit flag offensive delete publish link more


Thanks bspencer. I have it working now, thanks for the quick reply.

AAudio ( 2014-04-01 02:12:30 -0700 )edit

AAudio: are you successfully running the audio service with the embedded sound device of a Raspberry Pi or yours is a different platform? I have been trying to run the SinkService on the RPi and had the fast forward problem. When I add the asound libraries I run into this http://bit.ly/YYnQzq

germanviscuso ( 2014-10-03 16:33:41 -0700 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2014-03-30 23:25:30 -0700

Seen: 195 times

Last updated: Mar 31 '14