LampService 15.04 is not able to connect with Luminaire Android app

asked 2015-12-16 01:40:08 -0800

venkateshchimakurthi gravatar image

updated 2015-12-16 05:42:38 -0800

I am running the Lampservice (v15.04) in ubuntu and controller service in Android using Luminaire App. After On-boarding it is continuously sending only the MDNS messages. But in Luminaire I am not able to see it in available Lamps. Is it because of using older version of Luminaire (which has no support for MDNS)? In Google Play I didn't see any new version for Luminaire (.apk) and there is no source code available for 15.04. Can you please provide the Info on this.

edit retag flag offensive close merge delete

Comments

1

Given that com.qualcomm.luminaire Android app was last updated on Nov 18th 2014, it would likely be using 14.06 AllJoyn Routing node. 14.06 does have support for MDNS. Also, 15.04 ThinCore library has been tested to successfully discover 14.06 routing nodes. You might need to debug further.

praveenb ( 2015-12-16 12:29:07 -0800 )edit
2

Try 14.06 Routing node, alljoyn-daemon, running on Linux/Ubuntu and check whether 15.04 LampService is able to discover and connect to it. That will throw some light on whether it is a release version incompatibility.

praveenb ( 2015-12-16 12:30:10 -0800 )edit

Thanks praveen now it is working fine. My changes in LampService is causing the issue. With base code it is working fine.

venkateshchimakurthi ( 2015-12-21 23:42:01 -0800 )edit