1

How do I increase the number of "slots" available? (ER_CONNECTION_LIMIT_EXCEEDED)

asked 2015-10-06 05:55:43 -0700

adamwynne gravatar image

I am trying to test TCP and UDP signals with a large number of clients (48). In both cases I get the error "No slot for new connection: ER_CONNECTION_LIMIT_EXCEEDED." How do I increase the number of "slots" available?

edit retag flag offensive close merge delete

Comments

you should ask on the mailing list: https://lists.allseenalliance.org/mailman/listinfo/allseen-core

ry.jones ( 2015-10-06 14:18:44 -0700 )edit

Why? What is the purpose of this site if not to ask technical questions? We have asked a similar question here in the past and received a prompt answer. Thanks for the clarification

adamwynne ( 2015-10-16 05:43:25 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-10-16 00:09:21 -0700

praveenb gravatar image

updated 2015-10-20 16:40:33 -0700

The number of slots is a Transport parameter in the routing node configuration. The slots for TCP and UDP are configured as the same parameter max_completed_connections (the value applies to both TCP and UDP Transports).

You can find additional information here.

One thing to note is that the stand-alone routing node alljoyn-daemon has a capability to accept external configuration files via --config-file= option.

BundledRouter doesn't accept external configuration files by default. However, there is a scons option TEST_CONFIG with which you can specify a path to a configuration file that will be read by BundledRouter (and all apps using BR).

edit flag offensive delete publish link more

Comments

Thanks for the information! Since I was not aware of this config file, what I did was to change the max* values in the BundledRouter.cc file and recompile.

adamwynne ( 2015-10-16 05:44:42 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-10-06 05:55:43 -0700

Seen: 246 times

Last updated: Oct 20 '15