1

building on Windows10

asked 2015-09-17 14:30:18 -0800

GrahameHorner gravatar image

updated 2015-09-17 23:12:11 -0800

ry.jones gravatar image
Linux Foundation Staff

I have install VS2015, Python 2.7 and Scons to allow me to build the AllJoyn libraries; however I'm getting some errors (see below) what am I missing? any help would be great.

scons: warning: VC version 12.0 not installed.  C/C++ compilers are most likely not set correctly.
 Installed versions are: ['14.0']
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-09-17 23:14:53 -0800

ry.jones gravatar image
Linux Foundation Staff

The error tells you what you need to know: you need to install VS2013 to get VC12. If you check out the head of RB15.09 (or wait a few weeks for the 15.09 release) it will have VC14 support.

edit flag offensive delete publish link more

Comments

so the https://allseenalliance.org/developers/develop/building/windows page is incorrect? and VS2013 is required? I thought that may be the case, but give the page clearly states VS2015 I needed to verify. clear instructions on how to build are a must for this project to gain support from devs. thx

GrahameHorner ( 2015-09-18 01:41:53 -0800 )edit

I agree that the documentation is not clear. what version are you trying to build? this change was merged to master a while ago. https://git.allseenalliance.org/cgit/core/alljoyn.git/commit/?id=aee0cfacdec732ab250a735c3d06841f407f5bdc it isn't in 15.04.

ry.jones ( 2015-09-18 10:17:57 -0800 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-09-17 14:30:18 -0800

Seen: 77 times

Last updated: Sep 17 '15