Dashboard can't sync attached device information to each other

asked 2015-08-26 21:50:53 -0800

yellowcybertan gravatar image

hi all,

By my test that have total five ALLJOYN THIN CLIENT devices(using v14.06a ajtcl) and two mobile phone with official v14.12 Dashboard APP to monitor, I found device list of Dashboard APPs are shown differently, sometime Dashboard A show only two devices but Dashboard B show other three devices; sometimes Dashboard A show all of devices but Dashboard B show nothing. The issue also exist when I replace Dashboard to other bundled-router APP, ex, aboutlistener in sample code.

Compare with another case that only one Dashboard and the same five thin client devices, the device list always show correct(total five nearby devices) regardless how many times to restart thin client devices

Is it a bug? by my understand, ALLJOYN router(standalone or bundled) need to sync information(IS-ATs) with each other and establish the total topology to control?

edit retag flag offensive close merge delete

Comments

you might try on the core mailing list. https://lists.allseenalliance.org/mailman/listinfo/allseen-core

ry.jones ( 2015-08-26 22:42:17 -0800 )edit

It might be possible that this scenario of using two mobile phones running Dashboard was not comprehensively tested. You might want to open a JIRA ticket.

praveenb ( 2015-09-01 01:12:35 -0800 )edit

As indicated in the mail thread - details of your network setup are key here: if there is any kind of network partition with respect to multicast traffic that would explain the behavior you are seeing.

marcello ( 2015-09-01 10:56:06 -0800 )edit