1

Unable to connect sample Propeties Client with Propeties Service using 2 android devices connected to same wifi network

asked 2014-03-28 00:36:39 -0700

dharani335 gravatar image

updated 2014-03-28 10:15:10 -0700

Nikhil Dabhade gravatar image

Hi,

  1. I have installed Properties Service in one mobile and Propeties Client in another one.
  2. Connected both mobiles to same wifi network.
  3. Launched the Properties Service .
  4. When i launch the Properties Client, it is showing the Finding Propeties Service dialog. But it is not getting connected to Service and dialog keeps on running.

        If I run Client & Service in same mobile then it is working fine. 
        Please let me know If I am missing something.
    
edit retag flag offensive close merge delete

Comments

Hi Nikhil, Thanks for your inputs. As mentioned by you the problem was because multicast was blocked in the wifi network which I was using. I tried with multicasting on and the problem got resolved. Thanks :)

dharani335 ( 2014-04-01 23:31:02 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-03-28 10:04:10 -0700

Nikhil Dabhade gravatar image

Hi dharan335, Few things that you can check here is 1. Can you ping one device from the other connected to the same network? If this does not work then the Wi-Fi network could be restrictive and or blocking multicast which is the basis for AllJoyn discovery in its current form.

Let me know how it goes so that we can zero in on the problem.

Nikhil

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-03-28 00:36:39 -0700

Seen: 1,301 times

Last updated: Mar 28 '14