Enabling alljoyn on a specific interface (eth0/wlan0/wlan1)

asked 2014-10-13 03:30:41 -0700

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


I have enabled alljoyn server on Pandaboard and have installed 'Alljoyn Standard Library' on it. On the Pandaboard, I have eth0, wlan0 and wlan1 interfaces. How can I enable alljoyn framework to operate on a specific interface ? Is there any command to do this or can it be specified in the application developed above this framework ? please clarify.

Regards, Shashi

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-10-13 09:22:21 -0700

stevek gravatar image

If you are using the alljoyn-daemon for the routing node on your Pandaboard, you can create a configuration file that specifies which interfaces get used. You can look at alljoyn_core/router/test/conf/sample.conf as an example.

With AllJoyn 14.06 and older, making the appropriate changes is a bit cumbersome and somewhat limited. You can only have one listenspec for TCP and you can only specify an IP address. Unless you Pandaboard will be directly connected to the Internet (i.e., not behind a firewall), I suggest using addr= as the IP address which will cause AllJoyn to listen for incoming connections on all interfaces regardless of their IP address. You can then control which interfaces are used for advertising by changing the "ns_interfaces" property from * to a comma separated list of interfaces you want to use. It is important to understand that changing ns_interfaces only affects which interfaces AllJoyn uses for the purposes of discovery; it does not affect connectability.

With the upcoming AllJoyn 14.12 release and later, the configuration has simplified a bit. You will be able to specify multiple listenspecs for TCP and you will be able to use iface=eth0 (for example) to specify the interface. The listenspec also controls both which interface accepts incoming connects and which interface is used for advertising. Thus, there is no ns_interfaces property any more.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2014-10-13 03:30:41 -0700

Seen: 158 times

Last updated: Oct 13 '14