0

Can't build AllJoyn.unitypackage

asked 2014-09-18 10:42:27 -0700

uniquecorn gravatar image

Retried it a bunch of times. Reinstalled unity and so on. Running the cmd just doesn't create the unitypackage file. Using Unity 4.5.4

edit retag flag offensive close merge delete

Comments

The Unity module has not been looked at since a long time due to other things taking a priority. Can you share the cmd used by you ? Also there should be a unity package inside the Android SDK. Have you given that a try ?

Nikhil Dabhade ( 2014-09-18 15:32:37 -0700 )edit

"Starting with AllJoyn release 14.06, all Core Standard Library SDK's are built by the AllSeen Alliance. For AllJoyn's Unity binding, this means that the pre-built AllJoyn.unitypackage file can no longer be provided. The new SDK's include everything needed to create the AllJoyn.unitypackage, except the Unity IDE itself."

uniquecorn ( 2014-09-18 22:11:54 -0700 )edit

When I run the cmd I get an error. Aborting batchmode due to failure: Couldn't set project path to C:\Users\...\alljoyn-14.06.00-dbg\unity

uniquecorn ( 2014-09-18 22:24:28 -0700 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-09-20 14:40:11 -0700

bspencer gravatar image

Best guess is that the new version of unity has different command line arguments to create a .unitypackage. I would look at the.documentation for unity to check the command line arguments and then update the cmd you mention to use the new options. As mentioned in a comment, the Unity extension has not been looked at for some time.

edit flag offensive delete publish link more
0

answered 2014-11-03 08:37:59 -0700

JavierT gravatar image

It is not been looked for some time. Does it mean that we are not gonna have support? What solution can you offer in the meantime? It would be nice to have a package built while we continue getting this error.

Thanks

edit flag offensive delete publish link more

Comments

It's up to the Alliance. I would encourage you to ask the question to the members via the mailing list (https://lists.allseenalliance.org/mailman/listinfo/allseen-discuss) to see if a member of the Alliance will pick up this work.

bspencer ( 2014-11-10 14:10:30 -0700 )edit
0

answered 2014-12-08 07:22:09 -0700

EmFinn gravatar image

I hit the same problem recently.

Simple enough solution. The instructions in the zip are misleading.

You need to cd to "alljoyn-android\core\alljoyn-14.06.00a-rel\unity\package_support\UnityPackage" for the build, not "alljoyn-android\core\alljoyn-14.06.00a-rel\unity" as the instructions would have you believe.

edit flag offensive delete publish link more

Comments

this worked. Thanks!

andymule ( 2015-04-10 09:25:47 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-09-18 10:42:27 -0700

Seen: 395 times

Last updated: Dec 08 '14